I propose a new, more threatening kind of control flow.
do {
/* something */
} or else {
/* you don't want to find out */
}
Welcome to Programmer Humor!
This is a place where you can post jokes, memes, humor, etc. related to programming!
For sharing awful code theres also Programming Horror.
I propose a new, more threatening kind of control flow.
do {
/* something */
} or else {
/* you don't want to find out */
}
Some C++ style guides suggest the following naming convention for functions that crash on any error
OpenFileOrDie()
PHP has the always wonderful (and perfectly functional) syntax of
logUserIn() or die();
Personally, I like to call catched exception variables up
, so for a rethrow I can throw up;
.
this is just a menacing try/catch!
It_would_be_a_shame_if(condition)
The better try-catch. More intuitive if you ask me.
Please God let this be a humorous post that somehow does not also find a way to manage to come true...
I would have bought it if they said ifnot instead, it's the same number of characters and wouldn't require a major parser overhaul to support keywords with a ' in the name.
i mean, “unless” tends to be the usual term for an “if not” keyword in languages that implement such a thing
cap () {
}
nocap () {
}
nocap(frfr){
}
Reduce exclamation marks!? Great Scott!!!!! Is there a shortage of punctuation in the future!?
You could have saved two, all you had to do was use the interrobang. You’re a monster.
All known deposits were depleted
1.21GB!!!
ifn't(!valid)
halp?
I believe that resolves the same as
ain't!(!untrue)
Why not just ifnot? Same count of characters but an o instead of a possibly problematic single quote.
I think it's just capitalizing on a trend to add n't to otherwise noy contractions, to make them into contractions. Contractionn'ts, if you will
Yes... how is "reducing exclamation marks" a good thing when you do it by adding a '
(not to be confused with ,
´,
‘or
’` ..which are all different characters).
Does this rely on the assumption that everyone uses a US QWERTY keyboard where !
happens to be slightly more inconvenient than typing '
?
If someone really wanted to add it, probably the best would be to use unless
Still not as good as whence
Is this a reference to something because I’d love to read it if you have a time to share.
"Help's with readability"? You know what else helps? Not using contractions and introducing an unbalanced single quote.
I'm struggling to understand if this is true or ifn't true
Imagine the regex needed to highlight code with that extra single quote.
I'm just hoping this paves the way to code with Southern dialect
iffun is == true
iffun ain't == false
May I introduce you to the joys of #define and creating your own horrible sub language
With ahit like that its not microsoft java its now microsoft javascript
reminds me of #ifndef
instead of #if !defined(...)
This has to be illegal. I mean, it's basically suicide incitement (or whatever is the phrase for it)