1
337
submitted 3 months ago* (last edited 3 months ago) by [email protected] to c/[email protected]

Key points

  • Message notifications are back!
  • A big refresh to messaging
    • Added a new unified inbox option "all" combining comment replies, mentions and direct messages
    • Quick action buttons are now shown for comment replies, mentions and direct messages
    • Comment reply actions (more icon) now shows the user and community rows (with additional options)
    • Comment replies now show the community icon and post title
    • Comment replies have had a visual refresh
    • Comment replies, mentions and direct messages can now be quickly reported and marked as read
    • Comment replies, mentions and direct messages can now be marked as unread
    • Added a quickly reply swipe gesture
    • Added page dividers
    • Your own send direct messages can now be deleted
    • Direct messages are now shown in threads

New

  • Added .webm support to the image viewer and image peek
  • Added "linked instances" and "blocked instances" to the instance chip group

Changes

  • Experimenting with always showing the community icon in feeds
  • Updated the reply icon

Github issues closed

  • View mode not updating properly #402
  • No messages returned snackbar doesn't automatically go away #333
  • Add ability to disable "view more" toast messages #365
  • Allow images in comments to use shared element transitions #391
  • Add new app icons to replace the legacy S4R ones that were removed #389
  • Add option to swap upvote and down vote colors to match Lemmy #386
  • Username doesn't show in the account picker if there is no display name #451
  • Account settings save button not disappearing after saving #448
  • When swapping between automatic and manual theming, some elements don't change color properly #479
  • Override sort dialog shows cancel button twice #484
  • Username of non active account in account picker is empty #492
  • Crash on startup with latest update #445
  • Missing username in picker #478
  • Not showing link options properly and crashing when clicked #513

Other fixes

  • Fixed a title displaying issue caused by the recent change to titles
  • Fixed a crash when clicking link options on a text post
  • Fixed a bug where the description of the current messaging section in the toolbar wouldn't update correctly
  • Fixed an issue with a broken lift target in messaging causing the status bar not to change color

v122 adds support for a super secret upcoming new feature...

2
66
Markdown tests (lemmy.world)
submitted 3 months ago* (last edited 3 months ago) by [email protected] to c/[email protected]

If you come across something that doesn't work pop it here

3
195
Sync for Lemmy status page (syncforlemmy.betteruptime.com)
submitted 3 months ago* (last edited 3 months ago) by [email protected] to c/[email protected]

Evening all.

I've created a status page to monitor all services I maintain to run Sync for Lemmy.

There's not too many at the moment but will keep updating as I create new APIs etc.

Cheers, Lj

4
287
Upcoming releases (lemmy.world)
submitted 3 months ago by [email protected] to c/[email protected]

Hey everyone.]

So update 98/99 has gone live which fixes the crashes (thanks for the reports).

I'm gearing up for a pretty sizable release but just wanted to check in and ask if there was any issues you're having that I should know about or any new feature requests.

Sorry for the bad comms but I'm making my way through lots of messages and posts on here. Thanks for the patience as I get through these all.

Cheers, Lj

5
22
submitted 18 hours ago by [email protected] to c/[email protected]

What features would you most like to see implemented/updated?

6
7
Vote Scores Not Showing (midwest.social)
submitted 3 days ago by [email protected] to c/[email protected]

Hi there,

It seems that my midwest.social account has stopped showing the upvote count on posts and comments sometime over the last few days. My Lemmy.world and lemm.ee accounts show them fine still.

Ive tried logging out and back in and still no dice.

Anyone else having this bug?

Samsung Galaxy S24, latest play store build.

7
5
submitted 4 days ago* (last edited 4 days ago) by [email protected] to c/[email protected]

Anyone having a new issue where swiping from the left to go back to the thread list from a thread doesn't load properly and instead shows a black screen for a second or so.

Screen recording: https://imgur.com/a/bvzkyfu

All animations in the settings are enabled.

8
28
submitted 1 week ago* (last edited 1 week ago) by [email protected] to c/[email protected]

Recently I started noticing that a lot of posts will mark as read for a second then go back to unread when viewing just the image or article. It's not all posts though and I haven't determined a pattern yet, but opening the comments seems to mark as read on refresh even though the post looks unread before refreshing.

I'm on version 122 of Sync on Android.

9
42
submitted 2 weeks ago by [email protected] to c/[email protected]

Starting yesterday, when I click a link to view the image or comments, the link doesn't appear "read" when I go back to the feed.

I know Sync hasn't updated, but yesterday I updated Chrome and rebooted my phone, in case that's relevant.

I keep clicking the same posts over and over and can't use Hide Read option to only see new stuff.

10
10
submitted 2 weeks ago by [email protected] to c/[email protected]

I can't see what I'm typing in landscape orientation. I type in landscape 100% of the time.

11
5
submitted 2 weeks ago* (last edited 2 weeks ago) by [email protected] to c/[email protected]

It happened recently, the share function doesn't seem to be pulling the URL from the page.

Edit: this is with Firefox mobile beta 127.0b9 as my default browser

12
5
submitted 2 weeks ago by [email protected] to c/[email protected]
13
10
submitted 2 weeks ago* (last edited 2 weeks ago) by [email protected] to c/[email protected]

This is not happening on every post, but I'm seeing "There are no comments" more and more on posts where there are comments. The comment counter in the example pic shows 8. And I know there is at least one (I made a comment).

Any ideas?

Edit: I did try clearing cache and storage with no effect.

14
6
submitted 3 weeks ago* (last edited 3 weeks ago) by [email protected] to c/[email protected]

How can I see totals per up and down vote in sync? Right now it combines them.

15
3
Images not showing in body (lemmy.blahaj.zone)
submitted 3 weeks ago* (last edited 3 weeks ago) by [email protected] to c/[email protected]

Not sure if it's just me but I've noticed I've never seen any images in the body of a post on sync, though I have on a browser. I assumed in the past the user just forgot to add images but I now found a button to open them. Are they meant to be embedded in the large empty space?

Just incase this issue is widespread and nobody can see, Il note that I have attached 3 images showing the issue.

Device information

Sync version: v24.03.26-14:56    
Sync flavor: googlePlay    

Ultra user: false    
View type: Cards    

Device: Nord    
Model: OnePlus AC2003    
Android: 11
16
2
submitted 3 weeks ago by [email protected] to c/[email protected]

Can someone please check this comment I made and let me know if you see the inline image?

17
5
submitted 3 weeks ago by [email protected] to c/[email protected]
18
-11
I HATE school (medium.com)
submitted 3 weeks ago by [email protected] to c/[email protected]
19
11
submitted 3 weeks ago by [email protected] to c/[email protected]

I had posted this a few months and it's still the same issue.

If I search for a community using sync it only shows around 6-7. And that is also in the explore bar, it doesn't do the search in the dedicated search page.

Am I doing something wrong or is this still the case?

20
6
submitted 4 weeks ago by [email protected] to c/[email protected]

As the title asks, is it possible to migrate the settings for an account to a new phone? Would hate to have to set it up again..

21
20
submitted 1 month ago by [email protected] to c/[email protected]

I think a lot of people forget to check where they are before replying to things (me especially). Serious replies show up in shitposts and are then apologized for, joke comments are made in communities that are more serious, etc.

I was thinking it'd be nice to have the option to make me click through a confirmation of the community I'm in before crafting a data-driven response to something in an askmelolz group.

Bonus points for making it big and colorful :D

22
68
submitted 1 month ago* (last edited 1 month ago) by [email protected] to c/[email protected]

Sync grabs images using an option for max length of 1500px, so the super long images are just a smattering of pixels that barely represent the original image.

I can't find a way in the app to get a better quality version. I end up opening a web browser to view.

23
19
submitted 1 month ago* (last edited 1 month ago) by [email protected] to c/[email protected]

Edit: I'm pretty sure that I made a mistake here, in that I tried to use my main credentials to sign in and transfer, but I actually bought the lifetime on a different account. The likelihood that I confused myself with my paranoia is likely high.

24
5
submitted 1 month ago by [email protected] to c/[email protected]

Hey all. I'm having this issue where a bunch of content replies disappear on me. Or, rather, they are in my inbox, but when I click them to go reply and vote on them in the comments of the post where they are, they are completely missing from the thread/conversation. So to make it clear, they never disappear from my inbox, but they just can't be seen in the comments section itself, under the associated post.

Is this a bug or expected behavior?

Thanks for any help.

25
1
submitted 1 month ago by [email protected] to c/[email protected]

Links that open natively in Sync (like news articles) are often riddled with ads. Is there any way for the Sync shell to open through a Firefox based browser, which includes native ad block?

I'm not sure if this is related to what browsers I have on my phone. I do have one chromium based browser (kiwi) installed, and if getting rid of that would fix the problem I could look into deleting it and leaving only FF on my phone. But I'm not sure if it's related.

view more: next ›

Sync for Lemmy

14964 readers
56 users here now

👀


Welcome to Sync for Lemmy!

Download Sync for Lemmy


Welcome to the official Sync for Lemmy community.

The rules for posting and commenting, besides the rules defined here for lemmy.world, are as follows:

Community Rules


1- No advertising or spam.

All types of advertising and spam are restricted in this community.



Community Credits

Artwork and community banner by: @[email protected]


founded 1 year ago
MODERATORS